Troubleshooting 27th Edition CD Installation Problems

Machinery's Handbook 27 is designed to run on current Windows operating systems such as XP, Vista  and Windows 7. In addition, there are three essential requirements:

1. Correct Adobe Reader or Acrobat version
2. Correct Plugin
3. Authorization

Listed below are the three essential requirements in detail for getting Machinery's Handbook 27 to run. Additional information, including installation screen shots, is available on the CD in the file Instructions.pdf

1) You must first confirm the version of Adobe Reader that opens when you try to open the Machinery's Handbook CD. The Handbook works with any one of the following versions of Adobe Acrobat/Reader:

  • Adobe Reader or Acrobat Version 4.05 or greater
  • Adobe Reader or Acrobat Version 5.1 or greater
  • Adobe Reader or Acrobat Version 6.01 or greater
  • Adobe Reader or Acrobat Version 7.05 or greater
  • Adobe Reader or Acrobat Version 8.00 or greater
  • Adobe Reader or Acrobat Version 9.00 or greater
  • Adobe Reader or Acrobat X Version 10.1.1 or greater

You can obtain updates for Adobe Reader and Acrobat from www.adobe.com/support/downloads/.

Please check that you have one of the above versions installed. You can find the version number by opening Reader or Acrobat and clicking on Help and then About Adobe Reader or About Adobe Acrobat. The dialog that comes up contains the major version number in large numbers and elsewhere in smaller text is the full version number (i.e., 6.0.1 for example).

Important Notice for Adobe Reader/Acrobat Version 7 Users: If you are using Adobe Reader 7 or Acrobat 7, you must upgrade your software to version 7.05 or greater. Earlier versions (7.0.0, 7.0.1, 7.0.2, 7.0.3, etc.) cause an error when attempting to open some files on the CD.  If you try to open the Handbook 27 CD using either Adobe Reader Version 7, or Adobe Acrobat Version 7, and the version number is less than 7.0.5, then a message box will appear stating "Rebuild: The file is damaged but is being repaired".

Important Notice for Adobe Reader/Acrobat Version X (10) Users: If you are using Adobe Reader or Acrobat X (also known as version 10) , you must upgrade your Adobe software to Version 10.1.1 or greater. Earlier versions may cause an error when attempting to open some files on the CD.

Reader and Acrobat X users should also download and install the search index update for Machinery's Handbook 27. This update allows the use of the powerful Full Reader Search in Reader and Acrobat X. Download the update specific to the 27th edition CD version number printed on the face of the 27th edition CD.

Index upgrade for Machinery's Handbook 27 CD version 1.0

Index upgrade for Machinery's Handbook 27 CD version 1.00B

The update contains a zip archive containing a file, index27.pdx, and a directory index27 containing additional files. To install the update, replace the original index27.pdx and index27 directory with the new files contained in the update. Copy the downloaded zip archive into the Data directory at the location where Machinery's Handbook 27 is installed and extract the files to that location. The exact location where the updated files shoud be placed can be determined by opening the Handbook and selecting Properties from the File menu. On the Advanced tab, the location of the file index27.pdx is indicated in the field Search Index:.Replace the original index27.pdx and the index27 directory with the files from the zip archive.

Users of other versions of Reader and Acrobat do not require this update.

 2) Plugin Installation: The file foClientInstaller.exe is a small utility that is located in the Data directory of the 27th edition CD. This utility attempts to load a plugin in the plug_ins directory of the Acrobat or Reader product you are using. To run the utility, first be sure to close all open versions of Adobe Reader and Adobe Acrobat, and then double click on the foClientInstaller.exe file icon. You will see a short message from the program before it closes.

The fileOpen plugin fopen32.api must be installed in the Acrobat and/or Reader plugins directory. This is ordinarily handled by the installation program. If for some reason the plugin is not correctly installed, you may get a message similar to "A component required to perform this operation is missing," and the application may try to load the plugin from Adobe's website. If this occurs, you should still check that the correct plugin has been installed.

 You can check that the plugin is loaded in Adobe Reader by going to the Help menu, selecting About 3rd Party Plug-Ins, and you should see a listing for FileOpen. Click on FileOpen to see the version of the plugin that has loaded. For the 27th edition Handbook, Reader and Acrobat versions 7 and later require version 2.7.0.1 of the plugin. The plugin for all Reader and Acrobat version can be downloaded from the Industrial Press website by clicking on the following link:

FileOpen Plugin (v2.7.0.1) Installer

Be sure to close Adobe Acrobat before trying to install the plugin. 

You can also check for the presence of the plugin by using the Search feature and enter fopen32.api as the file name to search for. If the file is located, the path to it should be something similar to the following: C:\Program Files\Adobe\Reader 6.0\Reader\plug_ins or C:\Program Files\Adobe\Acrobat 6.0\Acrobat\plug_ins

3) Authorization: The handbook must be authorized by means of the installation program. If this step is not completed successfully, the Handbook CD will not run. Detailed instructions for installing and authorizing are included in the file Instructions.pdf located on the Machinery's Handbook 27 CD.